Intermittent loading issues

Incident Report for Housecall Pro

Resolved

This incident has been resolved.
Posted 4 years ago. Apr 30, 2021 - 10:30 PDT

Investigating

Some accounts are experiencing issues when attempting to load various parts of the software.
Posted 4 years ago. Apr 30, 2021 - 10:27 PDT