Email delivery issues
Incident Report for Housecall Pro
Resolved
This incident has been resolved.
Posted Jun 06, 2020 - 14:29 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 06, 2020 - 13:57 PDT
Update
We are continuing to investigate this issue.
Posted Jun 06, 2020 - 13:57 PDT
Investigating
We are currently investigating this issue.
Posted Jun 06, 2020 - 13:52 PDT
This incident affected: Email notifications.