Cloudflare Outage Impacting Integrations

Incident Report for Housecall Pro

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 10:55 PST

Update

Cloudflare continues to experience intermittent errors, but our services have largely recovered.
Posted Nov 18, 2025 - 08:36 PST

Update

Cloudflare continues to report that recovery is in process.
Posted Nov 18, 2025 - 07:59 PST

Update

Cloudflare is reporting that recovery is in process. We are monitoring the impact on our services.
Posted Nov 18, 2025 - 07:21 PST

Monitoring

Cloudflare is reporting that recovery is in process. We are monitoring the impact on our services.
Posted Nov 18, 2025 - 06:48 PST

Update

We are continuing to monitor Cloudflare's recovery.
Posted Nov 18, 2025 - 06:21 PST

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 05:53 PST

Update

Due to the ongoing Cloudflare issues, CSR AI calls are being forwarded directly to the designated forwarding number.
Posted Nov 18, 2025 - 05:36 PST

Investigating

We’re currently investigating an issue caused by a Cloudflare outage that is impacting integrations with Fundbox and Pipe.
Posted Nov 18, 2025 - 04:58 PST
This incident affected: CSR AI.