Temporary Service Outage

Incident Report for Housecall Pro

Resolved

This incident has been resolved.
Posted Oct 25, 2025 - 12:34 PDT

Investigating

Between (6:33 AM – 6:53 AM MT) on October 24, Housecall Pro experienced a 20-minute service outage that affected access for some users.
The issue was caused by a database update that temporarily impacted system availability. Our engineering team quickly identified the cause, restored service, and verified full system stability shortly after.
We’ve implemented additional safeguards in our release process to prevent similar incidents in the future.
Posted Oct 24, 2025 - 10:57 PDT