Customer call logs for some customers are currently unavailable via the iOS and Android apps
Incident Report for Housecall Pro
Resolved
This incident has been resolved.
Posted Sep 27, 2024 - 16:17 PDT
Identified
We have identified the issue and are actively working to remediate.
Posted Sep 27, 2024 - 06:56 PDT
This incident affected: Voice.