Customer Search for new and changed customers is delayed
Incident Report for Housecall Pro
Resolved
This incident has been resolved.
Posted Feb 02, 2024 - 20:55 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 02, 2024 - 18:05 PST
Update
We are continuing to investigate this issue.
Posted Feb 02, 2024 - 17:31 PST
Investigating
Our Customer Search is currently slow to add or change Customers. If you add a new customer, or change an existing one, that change will not show up in searches immediately.

We are diligently working to restore the service and appreciate your patience. Please subscribe to our status page to receive updates.
Posted Feb 02, 2024 - 16:32 PST
This incident affected: Pro web.