Web portal & app outage
Incident Report for Housecall Pro
Resolved
This incident has been resolved.
Posted Jun 08, 2020 - 14:27 PDT
Update
We are continuing to investigate this issue.
Posted Jun 08, 2020 - 14:26 PDT
Update
We are continuing to investigate this issue.
Posted Jun 08, 2020 - 14:25 PDT
Investigating
We are currently investigating this issue.
Posted Jun 08, 2020 - 14:25 PDT
This incident affected: Pro web, iOS Mobile App, and Android mobile app.