Slow load times and intermittent errors
Incident Report for Housecall Pro
Resolved
We have verified that our systems are now operating normally.
Posted Oct 19, 2021 - 17:14 PDT
Monitoring
The system is now fully operational and we are monitoring to ensure continued stability.
Posted Oct 19, 2021 - 16:21 PDT
Investigating
We're currently investigating long wait times on page loads as well as increased error responses accessing Housecall Pro.
Posted Oct 19, 2021 - 14:58 PDT
This incident affected: Pro web, Payment processing - Stripe, QuickBooks Online, Text notifications, Email notifications, Online booking, Google calendar, Consumer web, Add a job API, iOS Mobile App, Android mobile app, Customer job preview, Wisetack, and Responsibid.