Delayed job payment status for cash/check/other invoice payments (up to 1 hour)

Incident Report for Housecall Pro

Resolved

This incident has been resolved.
Posted Aug 11, 2026 - 16:34 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 11, 2026 - 15:55 PDT

Update

We are operational again.

RCA will be forthcoming.
Posted Aug 11, 2026 - 15:53 PDT

Update

The fix is being deployed.

Will post an update within the next 30 minutes.
Posted Aug 11, 2026 - 14:56 PDT

Update

We believe we have identified the issue and are testing a fix.

Will post an update within the next 30 minutes.
Posted Aug 11, 2026 - 14:17 PDT

Update

We are still investigating. The delay is now approximately 3 minutes.

Will post an update within the next 30 minutes.
Posted Aug 11, 2026 - 13:48 PDT

Update

We are still investigating. The delay is now approximately 30 minutes.

Will post an update within the next 30 minutes.
Posted Aug 11, 2026 - 13:18 PDT

Update

We are continuing to investigate this issue.
Posted Aug 11, 2026 - 12:59 PDT

Investigating

Payments are being processed; the status of cash, check, and other payments is delayed.

We are investigating the issue and will post an update by 1:15 pm Pacific Time.
Posted Aug 11, 2026 - 12:58 PDT
This incident affected: Payment processing - Stripe.