AWS US-East-1 Outage

Incident Report for Housecall Pro

Resolved

Resolved - At this time AWS is reporting full recovery. Services dependent upon AWS have fully recovered.
Posted Oct 20, 2025 - 03:26 PDT

Monitoring

Monitoring - At this time we are experiencing performance degradation across some products due to an ongoing AWS incident( https://health.aws.amazon.com/health/status ) with their US1 Region. We have activated our incident response team and have all hands on deck working on remediation. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 03:02 PDT
This incident affected: Text notifications and Voice.