Service Instability

Incident Report for Housecall Pro

Resolved

The infrastructure issue affecting multiple services across our website has been resolved. All services have returned to normal operation.
We will continue to monitor the environment to ensure stability. Thank you for your patience while we worked to resolve the issue.
Posted Sep 03, 2026 - 15:42 PDT

Update

We're seeing early signs of recovery from the cloud provider. We'll continue to monitor full service restoration.
Posted Sep 03, 2026 - 15:29 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2026 - 15:26 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 03, 2026 - 15:21 PDT

Update

We are continuing to investigate this issue.
Posted Sep 03, 2026 - 15:07 PDT

Investigating

We are experiencing infrastructure instability affecting multiple services across our website. Users may encounter intermittent errors, slower response times, or temporary service disruptions. We are actively investigating and working to restore normal service.
We’ll provide additional updates as more information becomes available.
Posted Sep 03, 2026 - 14:44 PDT
This incident affected: Pro web, Text notifications, Email notifications, iOS Mobile App, and Android mobile app.