Intermittent Server Load Issues
Incident Report for Housecall Pro
Resolved
Web and mobile apps have resumed normal functionality.
Posted Aug 21, 2020 - 12:59 PDT
Monitoring
Performance has improved over the past hour as we continue to monitor the situation. Web and mobile apps should start to show improvement and begin to communicate with the system normally.
Posted Aug 21, 2020 - 12:19 PDT
Update
We are continuing to investigate an unforeseen software versioning conflict with Amazon Web Services. All data is safe and backed-up, this is a load issue with the new version of the infrastructure, and the full engineering team is working directly with Amazon to resolve this issue.
Posted Aug 21, 2020 - 10:32 PDT
Update
We are experiencing an unforeseen conflict between software versions on Amazon Web Services that's causing a performance issue for some customers. All data is safe and backed-up, this is a load issue with the new version of the infrastructure, and the full engineering team is working directly with Amazon to resolve this issue.
Posted Aug 21, 2020 - 08:03 PDT
Update
We are continuing to investigate server load issues. Web and mobile apps may see degraded performance.
Posted Aug 21, 2020 - 07:03 PDT
Investigating
We are investigating follow on issues after our initial fix. Web and mobile apps may see degraded performance.
Posted Aug 21, 2020 - 06:16 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 21, 2020 - 06:02 PDT
Identified
The issue has been identified and a fix is rolling out to our servers. You should start to see improved performance on both web and mobile.
Posted Aug 21, 2020 - 05:59 PDT
Investigating
We are currently investigating this issue.
Posted Aug 21, 2020 - 05:41 PDT
This incident affected: Pro web, Text notifications, Email notifications, Online booking, Add a job API, iOS Mobile App, Android mobile app, and Customer job preview.