Google Calendar sync
Incident Report for Housecall Pro
Resolved
Google has resolved the issue and functionality should be fully restored. We are monitoring closely to ensure no further issues.
Posted Sep 21, 2023 - 10:07 PDT
Monitoring
Google is experiencing degraded performance with its Google Calendar API. This may be causing users to see error messages, experience latency, or other unexpected behavior when accessing their Google Calendar through Housecall Pro. They are working diligently to address the issue. Please subscribe to our status page to receive updates.
Posted Sep 21, 2023 - 09:15 PDT
Identified
We are investigating an issue with syncing Google calendars. Google API is experiencing degraded performance.
Posted Sep 21, 2023 - 07:49 PDT
This incident affected: Google calendar.